想从WP转到typecho遇到好几个问题。


我原来的wp是宝塔环境下安装的,php7.4,Nginx 1.21.0,目前正常使用WordPress的最新版本,然后最近想转换成typecho遇到了几个问题,
第一:我在WordPress根目录下解压了1.1-17.10.30-release.tar.gz,通过https://abc.com/build/install.php来安装typecho,顶部出现错误:

代码: 全选
Deprecated: Function get_magic_quotes_gpc() is deprecated in /www/wwwroot/abc.com/build/var/Typecho/Common.php on line 208


然后我输入和WordPress同数据库的账号密码,又提示:
代码: 全选
对不起,无法连接数据库,请先检查数据库配置再继续进行安装



所以就进行不下去了,求帮忙解决,谢谢了!
已邀请:

超级无敌小马甲

赞同来自:


我原来的wp是宝塔环境下安装的,php7.4,Nginx 1.21.0,目前正常使用WordPress的最新版本,然后最近想转换成typecho遇到了几个问题,
第一:我在WordPress根目录下解压了1.1-17.10.30-release.tar.gz,通过https://abc.com/build/install.php来安装typecho,顶部出现错误:

代码: 全选
Deprecated: Function get_magic_quotes_gpc() is deprecated in /www/wwwroot/abc.com/build/var/Typecho/Common.php on line 208


然后我输入和WordPress同数据库的账号密码,又提示:
代码: 全选
对不起,无法连接数据库,请先检查数据库配置再继续进行安装



所以就进行不下去了,求帮忙解决,谢谢了!

yucho

赞同来自:


问题1,可以看看这个帖子:https://forum.typecho.org/viewtopic.php?f=24&t=12317
问题2,尝试更换数据库适配器,或者使用新的数据库

要回复问题请先登录注册